This is an old revision of the document!


Export Gedcom File Plugin

This Plugin exports your GEDCOM and Media files in suitable formats to import into other genealogy products.

The philosophy is that fh holds the master database, and the exports are secondary copies for other products, perhaps to obtain online hints in Ancestry, FindMyPast, MyHeritage, etc, or to carry on a tablet when visiting record offices, churches, relatives, etc. Thus it is not critical that every tiny detail migrates from fh to the secondary product database. Migrating every detail is often not possible anyway, because of the various dialects of GEDCOM in use. Migrating the data back from the other product into fh is unlikely to succeed.

Export Gedcom File

Predominately, the Plugin eliminates fh GEDCOM Extension List custom tags, adheres to GEDCOM Standard Release 5.5 excluding non-standard tags, and introduces custom tags for some genealogy product dialects.

Media files can be exported in various formats or removed entirely.

The Export GEDCOM & Media … button creates the chosen format files in the export folder and offers to view them in fh, Notepad, or Explorer. If fh is chosen do NOT use Save or allow Autosave to upset the GEDCOM. Closing Options

If a subset of data is needed, use File > Import/Export > Export > GEDCOM File or File > Split Tree Helper first, and run this Plugin on the resultant GEDCOM as explained in the F.A.Q..

To avoid potential problems, it is advisable, before running the Plugin, to use the following:

  • File > Validate to detect Gedcom structural errors.
  • Tools > Uncategorised Data > Find Uncategorised Data or Tools > Plugins > UDF List to detect UDF.
  • Tools > External File Links to detect and repair broken Media links.
  • Tools > Plugins > Show Project Statistics to find invalid Dates and other potential problems.
  • Tools > Plugins > Check for Unlinked Media to reveal orphaned Media.
  • Tools > Plugins > Clean Living Persons to hide sensitive details.

Ensure the GEDCOM file imported to another product is selected from the Export folder, and if it reports level or other errors with line 1, then it probably does not recognise the chosen character encoding so try UTF-8 or ANSI instead.

See Basic Options, Extra Options, Other Options, Label Options, Output Formats, Output Media Style, Result Set, and F.A.Q. for details.

The Restore Defaults button resets all options and window positions & sizes to installation defaults, but only after a warning prompt.

The Set Window Fonts button will Set Window Fonts and Colours.

The Help & Advice button displays these online help pages. * The Close Plugin button terminates the Plugin without any export.

CC Attribution-Noncommercial-Share Alike 4.0 International
Runs using DokuWiki Recent changes RSS feed www.rjt.org.uk