Import from Generations Family Tree

Introduction

Generations was a popular Family History program, which has been discontinued and will not run on Windows 7 and above.

It's GEDCOM file is a little "eccentric" and in order to import it there are several recommended actions.

There are however for fh V5 & V6 a selection of Plugins which can help you migrate your files with minimal loss of data.

If it all looks too daunting, then My History and Jane Taubman offer paid for services to convert your data to fh format.

Before Exporting

Where possible before exporting your file, go through any custom tags and make sure any ones with standard GEDCOM tags are defined as such, for example, all Census Facts should have a tag of CENS. Don't worry if you can't do them all, as you can convert many of them later as required (see Keeping Required Custom Tags and Notes below).

Export your Gedcom File from Generations

  • Open the file you'd like to export to GEDCOM in Generations Family Tree.
  • Click on the File menu and move your mouse cursor down to Import/Export or Export, depending on which version of Generations you have.
  • Click on GEDCOM File…
  • Make sure that:
    • The Who box is set to All Individuals
    • Include sources is checked
    • Destination is set to Other if that option is available. Otherwise, set Destination to GEDCOM 5.5.
    • GEDCOM Character Set is set to Windows
    • Click the Export… button
  • Decide on a location to store your GEDCOM file so that you can easily retrieve it again.
  • Type a file name next to where it says File name. An example file name would be MyData.ged
  • Click Save.
  • Your file has now been exported.

Fixing the Source Notes

Generations exports source text incorrectly, and this needs to be fixed before loading the file into fh

  1. Download and install Generations Pre-Load Source Clean
  2. Open fh with the Family Historian Sample Project and run the Plugin selecting the file you exported above.
  3. A new file will be created in the same folder as your original file, prefixed with updated.

Create New Project in Family Historian

Check for word-wrapping errors

Use File > Project Window and the New Project button, and select Import a GEDCOM file. Browse to the updated copy of the GEDCOM file from above. Ensure Copy any linked multimedia files is ticked and click Next>. Enter the New Project Name and click Finish.

The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 2 words separated by a hyphen or let fh choose.

See Understanding Projects for more information on creating a Project from GEDCOM and Media files, and using the Project Window.

On the completion of the import an exception report will be created in Window > Log Files > Gedcom Report > View. Use Windows Notepad to search the report using the Find option for EXCLUDED. If you have any excluded lines, please post a question to the Forums with details.

At this stage do not worry about all the Unrecognised Data lines.

Inline Sources for Notes

These are not supported for fh, but you can keep the sources to the complete note, by changing the level of the Note field to 1 rather than 2. Ask in the Forums if unsure how to achieve this.

Cleaning up the Data

To correct any additional problems with Notes and Sources linked to them

  1. Download and Install Generations Post Edit
  2. Run this to fix a selection of errors to do with Notes and Sources

Keeping Required Custom Tags and Notes

To deal with custom tags that you wish to keep the best solution is to use the Change Any Fact Tag Plugin; please read the detailed help for this item.

Removing Unwanted Custom Tags and Notes

Finally download and use the plugin UDF List to clean up any remaining problem tags. See Handling Uncategorised Data Fields (UDF) for advice.

Clean Up Notes

Generations creates all notes as note records. If you would prefer to only have note records where they link to more than one record, download and run the Clean Up Notes Plugin.