Import from Family Tree Maker (FTM)

Introduction

Different versions of Family Tree Maker (FTM) have different database formats. Use the export to GEDCOM option, and from FTM 2012 image data is also exported, but prior to FTM 2012 scrapbook images are not exported. Note that any "source" images from Ancestry are not exported, so ensure all such images are saved to your PC while your Ancestry subscription is active. The FTM 2017 version by MacKiev is more GEDCOM compliant than previously, so observe any specific advice below for this version.

ƒh V6.2 has significantly enhanced features for FTM migrants, so be sure to upgrade if possible, as it is a free upgrade for V6 users. Click Check for Updates on the Help menu of ƒh if you want to confirm that you have the latest version. Users of the ƒh 30 Day Free Trial should be aware that it supports all features of ƒh except Family Historian Plugins.

Export GEDCOM from Family Tree Maker

File Export Dialogue

Export

  1. In FTM open the file you wish to export to GEDCOM.
  2. Choose File > Export to open the Export dialogue.
  3. In the Output Format dropdown list select GEDCOM 5.5.
  4. Select items to include such as private facts, private notes, or media files.
  5. Press OK.

Versions prior to FTM 2012/2014 may have other options,
so ensure Indent records is NOT ticked,
and that Abbreviate tags is ticked.

Export to GEDCOM Dialogue

Export to GEDCOM

  1. The Export to GEDCOM dialogue should now be open.
  2. Select Destination as Other.
  3. Select Character set as ANSI.
  4. Press OK.
  5. Decide on a location to store your GEDCOM file so that you can easily retrieve it later. A reasonable place to store your file might be your Desktop or My Documents. You can access these by clicking on the box next to Save in and scrolling all the way to the top. You will find both the Desktop and My Documents in that list.
  6. Next to where it says File name type a file name such as MyData.ged.
  7. Press Save.

Export Status Dialogue

Export Status

  1. The Export Status window should indicate the file exported successfully.
  2. Press OK.
  3. Your file has now been exported and is ready to be used to create a Project or opened directly in Family Historian (ƒh).

See Understanding Projects for more information on creating Projects from GEDCOM files using the File > Project Window.

Media Images

With ƒh V6.1 or later, any Media attached to Citations is easily found via the View Media dialogue as described in What’s New in Version 6.1.

For ƒh V6.0 or earlier, any Media attached to Citations may appear to vanish, but they are just being coy. They can be discovered on the All tab of the Individual's Property Box, but can also be revealed by using the toolbar camera icon View Media for selected Individual, and choose just the Source and Citation Media option. If you cannot find them ask for help in the Forums.

If you are using ƒh V5.0.8 or earlier, and need to migrate your Media files, then the GEDCOM file must be changed using a plain text editor such as Windows Notepad to replace every occurrence of 1 FILE with 1 _FILE , whereas later ƒh versions do not require this edit.

General Advice

In the latest ƒh V6.2 many of the problems below have been resolved as described in What’s New in Version 6.1 without the need for Quick Fix Plugins. A special custom Fact Set named Extended Set has been added to support the extended FTM facts.

Prior to FTM 2017, the Cause of Death was appended to the DEAT event tag, and when imported to ƒh automatically moved to the Death event local Note, but any existing Note hidden, except on the All tab. Thereafter, the Note can be manually moved to the Death event Cause field, and deleted. A similar problem may affect other facts with an FTM Description. Alternatively, use the Quick Fix Plugins method below.

If a Source Citation has both an Entry Date and Text From Source then an extra 3 DATA tag is produced. ƒh may convert these to 3 _DATA Uncategorised Data Fields. To correct the problem, use a plain text editor such as Windows Notepad on the exported GEDCOM file to find and delete the redundant 3 DATA tag lines, or use the Quick Fix Plugins below.

Source and Repository record 1 RFN tags are treated as Uncategorised Data Fields and fixed by Quick Fix Plugins below.

Some fact tags might be treated as Uncategorised Data Fields and may include:

  • 1 ADDR Address
  • 1 EMAIL Email
  • 1 PHON Phone
  • 1 _ELEC Elected
  • 1 _FUN Funeral
  • 1 _MDCL Medical
  • 1 _MILT Military

A fix for these in ƒh V6.2 is to use the Work with Fact Sets/Fact Types Extended Set. Alternatively, use the Quick Fix Plugins below, then the Change Any Fact Tag Plugin if you wish to alter the facts chosen by default.

Quick Fix Plugins

The problems identified above, and several others, can be fixed as explained below:

  • Before importing the GEDCOM file, use File > Project Window to open say the Family Historian Sample Project and use the ƒh command Tools > Preferences > File Load/Save and untick Move invalid data into note fields where possible to allow Death Cause to be easily detected and multiple Notes merged.
  • With FTM 2017 the CONCatenated long line word-wrapping has been corrected, and is mishandled by ƒh wrongly inserting space characters, while also inhibiting the Check for word-wrapping errors dialogue. The workaround is to use a plain text editor such as Windows Notepad to change the GEDCOM second line from 1 SOUR FTM to 1 SOUR OTHER, which enables that inhibited dialogue as described below.
  • Import the GEDCOM file via the ƒh command File > Project Window > New Project > Import a GEDCOM file. Ensure Copy any linked multimedia files into the new project folder is ticked. The dialogue is uncomplicated, but in the Check for word-wrapping errors window, select Each row contains 2 words separated by a hyphen, although it is reported that Each row contains 1 word with a hyphen in the middle works better especially for FTM 2017.

Check for word-wrapping errors

  • Use the ƒh command Window > Log Files to view a log of the problems mentioned above, but do NOT Delete the log file.
  • Install the import_from_ancestry_or_ftm.fh_lua Import From Ancestry or FTM Plugin into the Tools > Plugins window. However, this may not be needed from ƒh V6.2.

    Run this Plugin to produce a Result Set of changed Fields. Click any Field Value and choose Locate in Property Box or Locate in All Tab to open its Property Box for review. To cancel the Plugin changes, use Edit > Undo Plugin Updates before closing ƒh.

    If this Plugin hits problems, they may need resolving in FTM or by Handling Uncategorised Data Fields (UDF) for just the problem fields.
  • When satisfied with the results, use the ƒh command Tools > Preferences > File Load/Save and tick Move invalid data into note fields where possible to restore default setting.

Import Discussions