* Testing for unspecified individual (auto-text)

AS allows faster and more convenient creation of source records for Family Historian.
Post Reply
User avatar
ChrisRead
Diamond
Posts: 65
Joined: 10 Mar 2007 17:02
Family Historian: V7
Location: Wells, Somerset

Testing for unspecified individual (auto-text)

Post by ChrisRead » 22 Feb 2021 13:43

I was trying to test if an individual had been specified as otherwise it shows <No Name> as the output.
I assumed I could simply use =EQUALS[{KEYPERSON}%<No Name>] as a condition (actually using EQUALSNOT), but that does not appear to work as it always resolves to False regardless of whether I have specified an individual or not. So, I'm confused or doing the wrong thing.

Any guidance would be helpful.
Chris Read
Family Historian and Ancestral Sources user.

Researching the READ family and the myriad other relations that turned up.

User avatar
NickWalker
Megastar
Posts: 1439
Joined: 02 Jan 2004 17:39
Family Historian: V7
Location: Lancashire, UK
Contact:

Re: Testing for unspecified individual (auto-text)

Post by NickWalker » 22 Feb 2021 13:55

Hi Chris

You would need to 'escape' the < and > like this:

=EQUALS[{KEYPERSON}%\<No Name\>]

Alternatively you could use this:

=EQUALS[{KEYPERSON.ID}%]

Cheers

Nick
Nick Walker
Ancestral Sources Developer

http://www.ancestralsources.com

User avatar
ChrisRead
Diamond
Posts: 65
Joined: 10 Mar 2007 17:02
Family Historian: V7
Location: Wells, Somerset

Re: Testing for unspecified individual (auto-text)

Post by ChrisRead » 22 Feb 2021 13:58

I did wonder and tried it, but used the wrong escape slash :roll:

Thanks,

Chris
Chris Read
Family Historian and Ancestral Sources user.

Researching the READ family and the myriad other relations that turned up.

Post Reply