* Validation Report problem

Questions regarding use of any Version of Family Historian. Please ensure you have set your Version of Family Historian in your Profile
Post Reply
avatar
mardler
Gold
Posts: 26
Joined: 25 Jul 2013 17:22
Family Historian: V6.2
Location: Florida, USA
Contact:

Validation Report problem

Post by mardler » 20 Feb 2021 01:36

After my PC crash a couple of weeks ago, I reloaded my files from backups and received a validation report containing three lines of the kind:
"Individual Record Id=133201 (Henry Avenall): Male is linked to a family as spouse, but is not listed in the family as the husband. Family Id=40436 (...of Sarah Wheeler). Link has been removed."

I thought I had fixed it (from memory, I think I created another family and then merged them), but after deciding to buy a new laptop and reinstalling the program tonight I just had the very same messages again for the very same people.

Other than this, my database appears to be working OK - I touch wood as I say that!
Is there a way to fix the GED file, please? I'm not afraid to go in and edit it myself if that would fix it but if there's an easier way from within FH, that would be preferable.

Thank you in advance for any help anyone can be.
Paul

User avatar
tatewise
Megastar
Posts: 20571
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Re: Validation Report problem

Post by tatewise » 20 Feb 2021 11:06

Paul, I suspect the problem has existed for some time.
If you don't ever use the File > Validate... command then such errors can go undetected indefinitely.
It is only when the Project/GEDCOM is restored as a new Project will the validation get performed automatically.

The error message gives you all the details necessary to repair the problem without creating a new Family.
In the Records Window on the Families tab, locate Family ...of Sarah Wheeler with Record Id=40436.
Right-click that record and use Add Husband > Add Link to Existing Individual Record to choose Henry Avenall with Record Id=133201.

Finally, display that couple in the Focus Window and also use the File > Validate... command.
Create a new Backup.

That should fix the problem.

BTW:
If the Records Window has no Families tab then use Tools > Preferences > Records Window and set all tabs to Always show.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
mardler
Gold
Posts: 26
Joined: 25 Jul 2013 17:22
Family Historian: V6.2
Location: Florida, USA
Contact:

Re: Validation Report problem

Post by mardler » 21 Feb 2021 23:06

It did indeed. Thank you so much, Mike.
Appreciate the warning and will run a File/Validate to check.

Hah! The three error messages all said that a duplicate link of the man to the family has been removed! I promise you that I only fixed them once! At least the husbands are all now associated with their wives and children, which was the desired result.

Thanks again
Paul

Post Reply