* Plugin librarys compatible with V5, 6 & 7

A place for completed suggestions/corrections.

Moderator: kb admin

Post Reply
User avatar
tatewise
Megastar
Posts: 22836
Joined: 25 May 2010 11:00
Family Historian: V7
Location: Torbay, Devon, UK
Contact:

Plugin librarys compatible with V5, 6 & 7

Post by tatewise » 13 Sep 2021 12:17

The Writing and Maintaining Plugins Compatible with Versions 5, 6 & 7 advice has a section on Library Changes.
It only mentions IUP and would benefit having the following sentence in Library Changes before the IUP heading:

"See the Lua References and Library Modules advice for details of the library module versions supported by each ƒh version." [DONE]

Otherwise, the advice to consult the IUP History is little help if the user does not know the IUP Version for their FH Version.
It could suggest using tonumber(iup._VERSION) in a plugin to discover the version. [THIS IS IN THE FIRST CODE SNIPPET]

I think Lua References and Library Modules has a typo for the IUP versions shown in the table.
It should be V5: 3.5 and V6: 3.11.2 [FIXED]

The way version numbers are presented in all three tables is very inconsistent.
Some numbers have no prefix, some have capital V, some have lowercase v, and some have Version.
In the ƒh Version 7 column sometimes v7: is mentioned (redundandly) and sometimes not.
I expect people will be able to understand it

The utf8 library Notes box needs updating for FH v7.0.8.2 that has updated the utf8 library.
The line utf8 = require(".utf8"):init() for both ƒh6: and ƒh7: needs replacing with:
utf8 = require(".utf8")
require("utf8data")
utf8.config = { conversion = { uc_lc = utf8_uc_lc; lc_uc = utf8_lc_uc; } }
utf8:init()

[Done]
Last edited by ColeValleyGirl on 22 Sep 2021 11:59, edited 1 time in total.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

Post Reply