* PDF report with blank page 1

Questions regarding use of any Version of Family Historian. Please ensure you have set your Version of Family Historian in your Profile
Post Reply
avatar
MiriamSmith
Newbie
Posts: 4
Joined: 25 Feb 2019 02:25
Family Historian: V6.2
Location: Maryborough, Queensland

PDF report with blank page 1

Post by MiriamSmith » 25 Feb 2019 02:44

I apologise if the answer to my query is somewhere, but I couldn't find one. When I prepare a descendant report (for example), it all looks good and I'm ready to save it. I prefer to save it as a PDF, because it looks better than an RTF. However, the first page is usually blank. The second page will start in the middle of a sentence and is page 2 when it is in Family Historian, and therefore correct. Individual Narrative reports are fine, but not one with several generations. The report is correct other than page 1 being blank. What am I doing wrong? I have been using FH for several years and am now sharing with several cousins so need this report to 'look good'! Thank you, Miriam

User avatar
tatewise
Megastar
Posts: 16312
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: PDF report with blank page 1

Post by tatewise » 25 Feb 2019 10:40

Welcome to the FHUG Miriam. Sorry you are having that problem, which is quite uncommon.

Can I check a few things?
Presumably after using Save Report As > PDF File it indicates it is using the Family Historian PDF printer?
What PDF viewer program are you using ~ Adobe Acrobat Reader or something else?
What is your Windows version (10, 8.1, 7, Vista?) and is there anything unusual about it?
Have you customised the Publish > Narrative Reports > Descendants by Generation settings?
If so, then first use Save Report As > Custom Report Type to save those custom settings.
Then start again with standard Publish > Narrative Reports > Descendants by Generation and in Options click Installation Settings on each and every tab. Does that cure the problem? If so then try to identify which setting causes the upset.

If none of the above leads to a solution, it may a good idea to reinstall the Family Historian PDF printer driver.
But for now leave that until later.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
victor
Famous
Posts: 134
Joined: 08 Jan 2004 16:53
Family Historian: V6.2
Location: Thatcham, Berkshire, England

Re: PDF report with blank page 1

Post by victor » 25 Feb 2019 23:12

If you save the file in RTF format you can open the file and save it in any format you choose. A drop down list appears for you to pick in Word.
Once you have done that you can edit it, which you can't do in PDF (depends on where you get this from).

User avatar
tatewise
Megastar
Posts: 16312
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: PDF report with blank page 1

Post by tatewise » 25 Feb 2019 23:49

victor, thank you for that, but it only works if you have bought a licence for Word.
Anyway, the Save to PDF should work correctly and needs to be fixed.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
MiriamSmith
Newbie
Posts: 4
Joined: 25 Feb 2019 02:25
Family Historian: V6.2
Location: Maryborough, Queensland

Re: PDF report with blank page 1

Post by MiriamSmith » 26 Feb 2019 03:40

Hi Mike and Victor - thank you so much for your replies. Mike, I followed your instructions and have answers to your questions which I can't see now that I'm posting a reply! But the answers are Yes, Adobe, Windows 10, yes - I had made changes to 1 font size, number of photos and photo size. I reset to Installation Settings and the report did not change and it also shut down FH. I went into Printers and ran the troubleshooter on FH PDF but it didn't find any issues. So I rebooted the computer. Test 1 was 3 generations - no probs. Test 2 I changed the photo size - no probs. Test 3 I added an extra generation - no probs. Test 4 I added spouse family notes and spouse record notes - no probs. Test 5 I added extra photos to the report - woops. Only 1/2 the pages went to the report, the first page was blank and it shut down FH. Test 6 I had 3 photos each - individual, spouse and other (although I don't know what "other" actually refers to) - no probs. Test 7 I had photos 4,3,2 all medium size - no first page but at least there was a full report. Test 8 I had photos 3,3,2 all medium size - no probs. So it looks like I can't have more than 3 photos of medium size in a report for each individual and spouse. I have them in priority order anyway, but at least I now know.

Victor - one problem with an RTF report is that it doesn't look as good as a PDF especially with photos but it is a smaller file. My test 9, which was the RTF to PDF in Word ( I have full Microsoft 2007 applications) produced a PDF file that was 788Kb compared to direct PDF of 1.78Mb. This will be handy to know if I do a report on the descendants from 1600 to recent!!

Just as a background, I've been using FH ever since TMG announced it was closing and FH organised to be able to transfer data from TMG and I'd been using TMG for well over 10 years, plus I'm fairly computer savvy but this one had me stumped. So thank you both - I've taken both 'fixes' on board but disappointed that only 3 photos each for the individual and spouse can be put into the report. "Gold star" to both of you! Cheers from Queensland.

User avatar
tatewise
Megastar
Posts: 16312
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: PDF report with blank page 1

Post by tatewise » 26 Feb 2019 10:28

Miriam, that is great bit of detective work.

You ask about Picture Type: Other, which is NOT explained in the Help for Narrative Reports that needs updating.
For Individual Summary Reports the Help for the Pictures tab gives this explanation:
'Other' pictures means pictures for facts (that is, events or attributes) or Places, or both...

Please confirm whether the missing pages problems affect only the PDF output, or also the FH on-screen display.
That FH sometimes shutdown indicates an image may be upsetting the display driver.

Reports should allow up to 100 of each Picture Type of any Size.
So the problem is probably unique to the 4th Picture or subsequent Picture of one or more of the Individuals.
Could you please try changing the order of the images on the Media tab of the first Individual so that the 4th photo becomes the 1st and then try with it as the 5th. If possible repeat with other Individuals who have 4 or more photos.
In each case I suspect the problem occurs when Max Picts is equal to or greater than the rogue image position.

If that identifies particular images as the cause, then we ned to investigate why.
Do those suspect images use Link to Face frames?
If so, then check the frames are within the boundaries of the image, and don't stray outside.

There are other checks that can performed by hand, but it is easier to run the Show Project Statistics Plugin.
After using Update Statistics bottom left, click Close & Report.
In the Result Set lots of exceptions will be reported, but we are currently only interested in those right at the bottom labelled Unusual Multimedia Format/Frame that need correcting.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
MiriamSmith
Newbie
Posts: 4
Joined: 25 Feb 2019 02:25
Family Historian: V6.2
Location: Maryborough, Queensland

Re: PDF report with blank page 1

Post by MiriamSmith » 27 Feb 2019 07:49

Dear Mike - phew, what a day. First - the first missing page only affects the PDF - in FH all is well. I tried different order of photos various reports - kept crashing FH afterwards, empty first page and sometimes only 3/4 of the report went to PDF. Added photos, removed photos, drove myself mad. I downloaded the Plugin and ran it and there was no "Unusual Multimedia Format" error at all.

I then opened one of my other databases (I have four - my mum's side, my dad's, Rob's mum, Rob's dad's ancestors) and ran a report which had two photos in the 'main' chap although a couple of his grandchildren had lots. This report also did not work when saved to a PDF - empty first page and only 36 of 100 pages came into the report and FH crashed. So I opened up FH and ran the report again and saved it as a RTF (all good) and then as a PDF - all ok. I then ran the Plugin on this database and came up with heaps of Unusual Multimedia Format. I checked two of them and re-ran the Plugin and they were fixed. BUT, none of any of these photos were in this report! (I'll go back and look at everything on this report at a later date.....)

I went back to my first database and ran the report - 44 pages in FH. Saved to a PDF - only 24 pages, FH crashed BUT.... page 1 was there. I'm now wondering if FH doesn't like transferring jpgs that are very wide but narrow. For example - an entry from a parish register. Do you think this is an issue?? I can't think of anything else that could cause it. I've further tried multiple mixtures and finally it has only done 3 pages of the report and crashed FH......but had a proper page one. Sorry, but I am absolutely stumped now for ideas as to what to try next. Will sleep on it tonight...….. And from now on will just save as an RTF and further save to a PDF - that will fix it! Grrrrr.

User avatar
tatewise
Megastar
Posts: 16312
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: PDF report with blank page 1

Post by tatewise » 27 Feb 2019 11:33

Thank you for persevering Miriam.

If you have suspect images like your short & wide Parish Register image, then temporarily unlink it from the Media tab.
i.e. Click the bold red X and choose Unlink Only.
Try the Report, then use Edit > Undo Remove Link to Media Object to restore original set up.

Try an alternative method of PDF output.
In FH with the Report open, click Print button on the right, set Printer Name to Microsoft Print to PDF, then click OK and choose the filename to Save.
Open that saved PDF file to see if it is generated correctly.

I mentioned earlier that one solution might be to reinstall the Family Historian PDF printer driver.
See Knowledge Base > Save As PDF File Output is Not Enabled Option 1 for details.

If there is still no reliable solution, it may be necessary call in Calico Pie to help.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

avatar
MiriamSmith
Newbie
Posts: 4
Joined: 25 Feb 2019 02:25
Family Historian: V6.2
Location: Maryborough, Queensland

Re: PDF report with blank page 1

Post by MiriamSmith » 28 Feb 2019 04:00

Dear Mike
Another couple of hours and I think you've hit the jackpot. I unlinked 4 of the 6 jpgs and as well I re-did all the photos that were in pages 23-25 (where it had been stopping also) - even though they were all correct and well within the frame of the original photo. I then ran the report and it all worked - first page was there, it had 44/44 pages and FH did not crash. I re-linked those 4 jpgs one by one and ran the report inbetween each jpg and it kept on track. Sooooo, I think the problem is now solved. If this happens again, I'll know what to do - or at least where to start. All a learning curve and it's a bit like a couple of things I haven't been able to solve on FH reports that I could do on TMG (how to get the wife's surname to print instead of her maiden name once she's married and how to get a joint fact only print for one person and not both, ie repeated) but I guess the second one I could always save as an RTF first, delete the second story and then save as a PDF. Anyway - many many thanks for your infinite patience, I really appreciate it. Kind regards, Miriam.

User avatar
tatewise
Megastar
Posts: 16312
Joined: 25 May 2010 11:00
Family Historian: V6.2
Location: Torbay, Devon, UK
Contact:

Re: PDF report with blank page 1

Post by tatewise » 28 Feb 2019 09:30

Excellent :D
Persistence pays off.

Please post your other issues regarding specific Report options & features in a new thread.
Mike Tate ~ researching the Tate and Scott family history ~ tatewise ancestry

Post Reply